Excel Alfabetik Sıralama Formülü

Excel Sütunu Formül İle Alfabetik Sıralama



        Excel formülleri kullanarak , A sütunundaki verileri F sütununa alfabetik olarak (A-Z) sıraladık.
İlk olarak , Formüller Ad Yöneticisi menüsünden A2:A16 hücreleri için Liste adında bir isim tanımladık.


Tanımladığımız Ad  :     Liste=Sayfa1!$A$2:$A$16 

Daha sonra sütundaki verileri sıralamak için formülümüzü oluşturduk :
=İNDİS(Liste;KAÇINCI(KÜÇÜK(EĞERSAY(Liste;"<"&Liste);SATIR(1:1));EĞERSAY(Liste;"<"&Liste);0))

Herhangi bir hücre seçilerek , formül çubuğuna yukarıdaki formülü yapıştırdıktan hemen sonra dizi formül olduğu için CTRL+SHIFT+ENTER tuşlarına aynı anda basarız . Formülün başına ve sonuna { } karakterlerinin eklendiğini gözlemleyebilirsiniz.
        Hücrede, örneğimizdeki A harfi ile başlayan ilk değer olan ASİYE AÇ ismi görüntülenir. Şimdi bu hücre seçili iken ,hücrenin sağ alt köşesine geldiğimizde  + işareti belirir , + işareti ekrandan kaybolmadan sağ alt köşeden tutarak aşağıya doğru sürükleme işlemini yaparız ve işte isimler alfabetik olarak sıralanmış oldu.


Ad tanımlama yapmadan da direkt olarak formül şu şekilde pratik olarak kullanılabilir :
=İNDİS($A$2:$A$16;KAÇINCI(KÜÇÜK(EĞERSAY($A$2:$A$16;"<"&$A$2:$A$16);SATIR(1:1));EĞERSAY($A$2:$A$16;"<"&$A$2:$A$16);0))

Excel'de formül ile veri sıralamayı dinamik hale getirmek için örneğin ; A2:A16 aralığındaki hücrelerden birinin veya birkaçının değeri değiştiğinde , sıralamayı hemen güncellemek için şu sıralama formülü kullanılabilir :
 =EĞERHATA(İNDİS($A$2:$A$16;KAÇINCI(KÜÇÜK(EĞERSAY($A$2:$A$16;"<"&$A$2:$A$16);SATIR(1:1));EĞERSAY($A$2:$A$16;"<"&$A$2:$A$16);0));"")

Bazı durumlarda alfabetik sıralamak istediğimiz sütunda boş hücre veya sayı olabilir ;

 bu gibi durumlarda ,düzgün bir sıralama sağlamak için formülümüzü şu şekilde kullanabiliriz :

=EĞERHATA(İNDİS($A$2:$A$16;KAÇINCI(KÜÇÜK(DEĞİL($A$2:$A$16="")*EĞER(ESAYIYSA($A$2:$A$16);EĞERSAY($A$2:$A$16;"<="&$A$2:$A$16);EĞERSAY($A$2:$A$16;"<="&$A$2:$A$16)+TOPLAM(--ESAYIYSA($A$2:$A$16)));SATIRSAY($A$2:A2)+TOPLAM(--EBOŞSA($A$2:$A$16)));DEĞİL($A$2:$A$16="")*EĞER(ESAYIYSA($A$2:$A$16);EĞERSAY($A$2:$A$16;"<="&$A$2:$A$16);EĞERSAY($A$2:$A$16;"<="&$A$2:$A$16)+TOPLAM(--ESAYIYSA($A$2:$A$16)));0));"")

Örnek dosyaları buradan indirebilirsiniz:excel veri doğrulama listesi benzersiz sıralı değerler içerir

No comments:

Post a Comment